1. 문제점
- 아래와 같이 lvm 명령어를 치면 에러가 나온다.
[root@rhcs03 ~]# pvscan
connect() failed on local socket: No such file or directory
Internal cluster locking initialisation failed.
WARNING: Falling back to local file-based locking.
Volume Groups with the clustered attribute will be inaccessible.
No matching physical volumes found
2. 해결방안
1) Redhat
-----------------------------------------------------------------------------------------
해결
Please use following steps to enable use_lvmetad option in lvm.conf:
1) Stop the lvm2-lvmetad service:
Raw
$ service lvm2-lvmetad stop
2) Set use_lvmetad = 1 in /etc/lvm/lvm.conf file:
Raw
use_lvmetad = 1
3) Restart the lvm2-lvmetad service:
Raw
$ service lvm2-lvmetad start
-----------------------------------------------------------------------------------------
2) 내가 알아낸 방법
- 원인은 clvmd 를 사용하면서, locking_type 을 기존 1에서 3으로 변경해서 생긴일이다.
# vim /etc/lvm/lvm.conf | grep locking_type
locking_type = 1 // 1로 원복 혹은 수정
|